Kerberos () is a computer-network authentication protocol that works on the basis of tickets to allow nodes communicating over a non-secure network to prove their identity to one another in a secure manner. Its designers aimed it primarily at a client–server model, and it provides mutual authentication—both the user and the server verify each other's identity. Kerberos protocol messages are protected against eavesdropping and replay attacks.
Kerberos builds on symmetric-key cryptography and requires a trusted third party, and optionally may use public-key cryptography during certain phases of authentication. Kerberos uses UDP port 88 by default.
The protocol was named after the character Cerberus, also spelled Kerberos, from Greek mythology, the ferocious three-headed guard dog of Hades.
Contents
History and development
The Massachusetts Institute of Technology (MIT) developed Kerberos in 1986 to protect network services provided by Project Athena. Its first version was primarily designed by Steve Miller and Clifford Neuman based on the earlier Needham–Schroeder symmetric-key protocol. Kerberos versions 1 through 3 were experimental and not released outside of MIT.
Kerberos version 4, the first public version, was released on January 24, 1989. Since Kerberos 4 was developed in the United States, and since it used the Data Encryption Standard (DES) encryption algorithm, U.S. export control restrictions prevented it from being exported to other countries. MIT created an exportable version of Kerberos 4 with all encryption code removed, called "Bones". Eric Young of Australia's Bond University reimplemented DES into Bones, in a version called "eBones", which could be freely used in any country. Sweden's Royal Institute of Technology released another reimplementation called KTH-KRB.
Neuman and John Kohl published version 5 in 1993 with the intention of overcoming existing limitations and security problems. Version 5 appeared as RFC 1510, which was then made obsolete by RFC 4120 in 2005.
In 2005, the Internet Engineering Task Force (IETF) Kerberos working group updated specifications. Updates included:
Encryption and Checksum Specifications (RFC 3961).
Advanced Encryption Standard (AES) Encryption for Kerberos 5 (RFC 3962).
A new edition of the Kerberos V5 specification "The Kerberos Network Authentication Service (V5)" (RFC 4120). This version obsoletes RFC 1510, clarifies aspects of the protocol and intended use in a more detailed and clearer explanation.
A new edition of the Generic Security Services Application Program Interface (GSS-API) specification "The Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Mechanism: Version 2" (RFC 4121).
Protocol
Description
The client authenticates itself to the Authentication Server (AS) which is part of the key distribution center (KDC). The KDC issues a ticket-granting ticket (TGT), which is time stamped and encrypts it using the ticket-granting service's (TGS) secret key and returns the encrypted result to the user's workstation. This is done infrequently, typically at user logon; the TGT expires at some point although it may be transparently renewed by the user's session manager while they are logged in.
When the client needs to communicate with a service on another node (a "principal", in Kerberos parlance), the client sends the TGT to the TGS, which is another component of the KDC and usually shares the same host as the authentication server. The service must have already been registered with the TGS with a Service Principal Name (SPN). The client uses the SPN to request access to this service. After verifying that the TGT is valid and that the user is permitted to access the requested service, the TGS issues a service ticket (ST) and session keys to the client. The client then sends the ticket to the service server (SS) along with its service request.
The protocol is described in detail below.
A user enters a username and password on the client machine. Other credential mechanisms like PKINIT (RFC 4556) allow for the use of public keys or smart cards in place of a password.
The client transforms the password into a symmetric key using a one-way hash or standard key derivation function, depending on the cipher suite used.
In modern Kerberos (v5), the client often uses this key to encrypt a current timestamp. This encrypted timestamp is sent to the AS along with the username as "pre-authentication" to prove the user knows the password before the AS issues any tickets, preventing offline brute-force attacks.
The client sends a plaintext message of the user ID to the AS (Authentication Server) requesting services on behalf of the user. (Note: Neither the secret key nor the password is sent to the AS.)
Support by operating systems
Microsoft Windows
Windows 2000 and later versions use Kerberos as their default authentication method. Some Microsoft additions to the Kerberos suite of protocols are documented in RFC 3244 "Microsoft Windows 2000 Kerberos Change Password and Set Password Protocols". RFC 4757 documents Microsoft's use of the RC4 cipher. While Microsoft uses and extends the Kerberos protocol, it does not use the MIT software.
Kerberos is used as the preferred authentication method: in general, joining a client to a Windows domain means enabling Kerberos as the default protocol for authentications from that client to services in the Windows domain and all domains with trust relationships to that domain.
In contrast, when either client or server or both are not joined to a domain (or not part of the same trusted domain environment), Windows will instead use NTLM for authentication between client and server.
Internet web applications can enforce Kerberos as an authentication method for domain-joined clients by using APIs provided under SSPI.
Microsoft Windows and Windows Server include setspn, a command-line utility that can be used to read, modify, or delete the Service Principal Names (SPN) for an Active Directory service account.
Unix and other operating systems
Many Unix-like operating systems, including FreeBSD, Apple's macOS, Red Hat Enterprise Linux, Oracle's Solaris, IBM's AIX, HP-UX and others, include software for Kerberos authentication of users or services. A variety of non-Unix like operating systems such as z/OS, IBM i and OpenVMS also feature Kerberos support. Embedded implementation of the Kerberos V authentication protocol for client agents and network services running on embedded platforms is also available from companies.
Drawbacks and limitations
Kerberos has strict time requirements, which means that the clocks of the involved hosts must be synchronized within configured limits. The tickets have a time availability period, and if the host clock is not synchronized with the Kerberos server clock, the authentication will fail. The default configuration per MIT requires that clock times be no more than five minutes apart. In practice, Network Time Protocol daemons are usually used to keep the host clocks synchronized. Note that some servers (Microsoft's implementation being one of them) may return a KRB_AP_ERR_SKEW result containing the encrypted server time if both clocks have an offset greater than the configured maximum value. In that case, the client could retry by calculating the time using the provided server time to find the offset. This behavior is documented in RFC 4430.
The administration protocol is not standardized and differs between server implementations. Password changes are described in RFC 3244.
In case of symmetric cryptography adoption (Kerberos can work using symmetric or asymmetric (public-key) cryptography), since all authentications are controlled by a centralized key distribution center (KDC), compromise of this authentication infrastructure will allow an attacker to impersonate any user.
Each network service that requires a different host name will need its own set of Kerberos keys. This complicates virtual hosting and clusters.
Kerberos requires user accounts and services to have a trusted relationship to the Kerberos token server.
The required client trust makes creating staged environments (e.g., separate domains for test environment, pre-production environment and production environment) difficult: Either domain trust relationships need to be created that prevent a strict separation of environment domains, or additional user clients need to be provided for each environment.
Security
The Data Encryption Standard (DES) cipher can be used in combination with Kerberos, but is no longer an Internet standard because it is weak. Security vulnerabilities exist in products that implement legacy versions of Kerberos which lack support for newer encryption ciphers like AES.



